Mémo kerberos/samba/ftps

Par Cinux, le 08 juillet 2018Lire la suite

Je me suis fait un petit mémo lors de la mise en place de serveurs linux dans le cadre d'un projet d'étude. Il était demandé de mettre en place un serveur ftps permettant de partager des fichiers avec les clients externes à l'entreprise. -- Lire la doc --

Au programme :

  • Quelques outils pour sécuriser un serveur sous GNU/linux
  • Ajouter le serveur au domaine de l'entreprise et/ou autoriser les utilisateurs du domaine à se connecter
  • Configurer un partage SMB
  • Configurer un serveur FTPS qui donne accès au partage samba avec des comptes cloisonnés pour les utilisateurs du ftp, tout en permettant aux utilisateurs d'un groupe du domaine d'accéder aux dossiers des utilisateurs via SMB.

VLC sous Archlinux

Par Cinux, le 22 août 2017Lire la suite

Si comme moi, après l'installation de vlc, rien ne se passe quand vous le lancez, essayez de lancer la commande 'vlc' dans un terminal afin de voir si l'erreur suivante d'affiche

$ vlc
[0000006181cd9148] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
[0000006181e1a818] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0000006181e1a818] skins2 interface error: cannot instantiate qt4 dialogs provider
Il est fort possible que qt4 ne soit pas installé car il ne l'est pas automatiquement. En effet, si vous tapez :
$ pacman -Qi vlc
Vous constaterez que la lib qt4 est optionnelle car on peut lancer vlc sans interface de commande grace à la commande cvlc. Pour installer qt4 tapez :
$ sudo pacman -Syu qt4
Enjoy....

Debian 9 (Stretch) est là!

Par Cinux, le 22 juin 2017Lire la suite

La dernière version (9) de Debian est sortie. Son nom de code est Stretch. Vous pouvez la télécharger librement à sur le site officiel https://www.debian.org/.
Sinon, si vous êtes déjà sous debian 8 (Jessie) vous pouvez mettre votre système à jour comme ceci:

1) Pour être bien sûre d'être à jour :
apt-get update && apt-get upgrade

2) On modifie le fichier sources.list et on remet la liste des paquets à jour :
sed -i 's|jessie|stretch|' /etc/apt/sources.list && apt-get update

3) On lance le changement de version :
apt-get dist-upgrade

4) On redémarre et on s'éclate!

Debian 9 est gelée!

Par Cinux, le 12 février 2017Lire la suite

https://tuxicoman.jesuislibre.net/2017/02/freeze-de-debian-9.html
On va enfin passer au noyau 4.9 ^^